Creates a new shaft opening between a set of levels.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- bottomLevel
- Type: Autodesk.Revit.DB Level
bottom level
- topLevel
- Type: Autodesk.Revit.DB Level
top level
- profile
- Type: Autodesk.Revit.DB CurveArray
profile of the opening.
Return Value
If successful, an Opening object is returned.Remarks
This method forms an opening on floor, ceiling and roof. Make sure topLevel is higher than bottomLevel, otherwise an exception will be returned.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown if the bottom level does not exist in the given document. |
Autodesk.Revit.Exceptions ArgumentException | Thrown if the top level does not exist in the given document. |