Checks if the rod is locked with the host. The method is applicable only for bearer hanger.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)
Since:
2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- rodIndex
-
Type:
System
Int32
The index of the rod.
Return Value
True if the rod is locked with its host.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | the index rodIndex is should be in range of rod count. |
Autodesk.Revit.Exceptions InvalidOperationException | The hanger is not a bearer hanger. |