Checks if given Reference identifies either a valid element or subelement.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since:
2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- aDoc
-
Type:
Autodesk.Revit.DB
Document
The document.
- reference
-
Type:
Autodesk.Revit.DB
Reference
The reference that identifies an element or subelement.
Return Value
True if %reference% identifies a valid element or subelement, false otherwise.Remarks
A reference to an element or subelement in a linked document is acceptable.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |