Calculates the intersection of this curve with the specified curve.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- curve
- Type: Autodesk.Revit.DB Curve
The specified curve to intersect with this curve.
Return Value
- SetComparisonResult.Overlap - One or more intersections were encountered.
- SetComparisonResult.Subset - The inputs are parallel lines with only one common intersection point, or the curve used to invoke the intersection check is a line entirely within the unbound line passed as argument curve.
- SetComparisonResult.Superset - The input curve is entirely within the unbound line used to invoke the intersection check.
- SetComparisonResult.Disjoint - There is no intersection found between the two curves.
- SetComparisonResult.Equal - The two curves are identical.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | The specified curve is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions InvalidOperationException | Failed to calculate the intersection. |