Connects a pair of placeholders that can intersect in an Elbow connection.
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- placeholder1Id
- Type: Autodesk.Revit.DB ElementId
The element id of the first duct placeholder.
- placeholder2Id
- Type: Autodesk.Revit.DB ElementId
The element id of the second duct placeholder.
Return Value
True if connection succeeds, false otherwise.Remarks
The placeholders must meet at a physical end connection. If connection fails, the placeholders cannot be physically connected.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The element id placeholder1Id is not duct placeholder. -or- The element id placeholder2Id is not duct placeholder. -or- The elements belong to different types of system. -or- The curve placeholder1Id and placeholder2Id are not physically connected. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |