FamilyItemFactory Class


The Family Item Factory object is used to create new instances of elements within the Autodesk Revit Family.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public class FamilyItemFactory : ItemFactoryBase
Visual Basic
Public Class FamilyItemFactory _
	Inherits ItemFactoryBase
Visual C++
public ref class FamilyItemFactory : public ItemFactoryBase

Remarks

The Family Item Factory object is a utility object that is used to create new instances of elements within the Autodesk Revit Family Document. This object should be used to create elements instead of using New. This object ensures that the elements created are added to the family document correctly.

Inheritance Hierarchy

See Also