Creates object from an array of domain point values
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- valueAtPoint
- Type: System.Collections.Generic IList ValueAtPoint
Array of values, each corresponding to a domain point
- unitDirection
- Type: Autodesk.Revit.DB XYZ
Unit vector that gives the same direction for values (for diagrams)
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Members of valueAtPoint contain different numbers of measurements -or- unitDirection is not a unit vector |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |