Sets the position of the rod end. The method is applicable only for bearer hanger.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- rodIndex
- Type: System Int32
The index of the rod.
- position
- Type: Autodesk.Revit.DB XYZ
The position of the rod end.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Invalid rod position. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | the index rodIndex is should be in range of rod count. |
Autodesk.Revit.Exceptions InvalidOperationException | The hanger is not a bearer hanger. |