DesignToFabricationConverter Class


This class represents the MEP design to fabrication part convert tool.

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2017

Syntax

C#
public class DesignToFabricationConverter : IDisposable
Visual Basic
Public Class DesignToFabricationConverter _
	Implements IDisposable
Visual C++
public ref class DesignToFabricationConverter : IDisposable

Remarks

After a new instance of the class is created, call the Convert method to convert the MEP design elements into fabrication parts. After the convert method has been invoked, query the class to obtain more information about the conversion:

Inheritance Hierarchy

System Object
Autodesk.Revit.DB.Fabrication DesignToFabricationConverter

See Also