FloorType Class


An object that specifies the type of a floor in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public class FloorType : HostObjAttributes
Visual Basic
Public Class FloorType _
	Inherits HostObjAttributes
Visual C++
public ref class FloorType : public HostObjAttributes

Remarks

The structural layers of the floor can be accessed via this object.

Examples

Copy C#
public void GetInfo_FloorType(FloorType floorType)
{
    string message;
    // Get whether FloorType is a foundation slab
    message = "If is foundation slab : " + floorType.IsFoundationSlab;
    TaskDialog.Show("Revit",message);
}
Copy VB.NET
Public Sub GetInfo_FloorType(floorType As FloorType)
    Dim message As String
    ' Get whether FloorType is a foundation slab
    message = "If is foundation slab : " & Convert.ToString(floorType.IsFoundationSlab)
    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

See Also