Used to determine whether the element supports the given parameter.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- element
- Type: Autodesk.Revit.DB Element
The element to query for support of the given parameter.
- parameter
- Type: Autodesk.Revit.DB ElementId
The parameter for which to query support.
Return Value
True if the element supports the given parameter, false otherwise.Remarks
This operation is supported for external (e.g., shared, project) parameters only.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |