Tests whether a dimension can be labeled by the global parameter.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2016 Subscription Update
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- dimensionId
- Type: Autodesk.Revit.DB ElementId
Id of a dimension element.
Return Value
True of the input dimension can be labeled by this global parameter; False oterwise.Remarks
Possible causes include a dimension that cannot be labeled at all, or it is of other than Linear or Angular type, or does not have the appropriate labeling parameter. Another reason for this method returning False is that the data type of this global parameter is not suitable for labeling (i.e. it contains neither Length nor Angle value), or the parameter is reporting and the dimension has more than one segment.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |