The DefinitionFile object represents a shared parameters file on disk.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)
Syntax
Remarks
Shared Parameters are parameter definitions that are stored in a text file
external to the Autodesk Revit project. These definitions can be used in multiple projects
and are identifiable by a unique identifier generated when they are created. API access to
shared parameters consist of a number of objects, the first of which is an object that
represents the shared parameters file on disk. That object then contains a number of Group
objects. Shared parameters are grouped for easier management. These groups then contain the
shared parameter definitions. The groups support the ability to create new shared
parameter definitions. The DefinitionFile object can be retrieved by the
Application.OpenSharedParameterFile method.
Examples
Copy
C#
private void ShowDefinitionFileInfo(DefinitionFile myDefinitionFile)
{
StringBuilder fileInformation = new StringBuilder(500);
// get the file name
fileInformation.AppendLine("File Name: " + myDefinitionFile.Filename);
// iterate the Definition groups of this file
foreach (DefinitionGroup myGroup in myDefinitionFile.Groups)
{
// get the group name
fileInformation.AppendLine("Group Name: " + myGroup.Name);
// iterate the difinitions
foreach (Definition definition in myGroup.Definitions)
{
// get definition name
fileInformation.AppendLine("Definition Name: " + definition.Name);
}
}
TaskDialog.Show("Revit",fileInformation.ToString());
}
Copy
VB.NET
Private Sub ShowDefinitionFileInfo(myDefinitionFile As DefinitionFile)
Dim fileInformation As New StringBuilder(500)
' get the file name
fileInformation.AppendLine("File Name: " & Convert.ToString(myDefinitionFile.Filename))
' iterate the Definition groups of this file
For Each myGroup As DefinitionGroup In myDefinitionFile.Groups
' get the group name
fileInformation.AppendLine("Group Name: " + myGroup.Name)
' iterate the difinitions
For Each definition As Definition In myGroup.Definitions
' get definition name
fileInformation.AppendLine("Definition Name: " + definition.Name)
Next
Next
TaskDialog.Show("Revit", fileInformation.ToString())
End Sub