Sets the structural section in element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- structuralSection
- Type: Autodesk.Revit.DB.Structure.StructuralSections StructuralSection
Structural section with values that will be set.
Remarks
Only beams, braces and structural columns can have a structural section. To check if the element can have structural section use the [!:Family.HasStructuralSection()] method.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | This FamilySymbol cannot have a structural section. |