Applies an ElementCategoryFilter to the collector.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- category
- Type: Autodesk.Revit.DB BuiltInCategory
The category.
Return Value
This collector.Remarks
Only elements of this category id will pass the collector.
Examples

// Use OfCategory method to apply an ElementCategoryFilter and fine elements in the Doors category
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> doors = collector.OfCategory(BuiltInCategory.OST_Doors).ToElements();

' Use OfCategory method to apply an ElementCategoryFilter and fine elements in the Doors category
Dim collector As New FilteredElementCollector(document)
Dim doors As ICollection(Of Element) = collector.OfCategory(BuiltInCategory.OST_Doors).ToElements()