Creates a new shared parameter element in the document representing the parameter stored in the input ExternalDefinition.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- sharedParameterDefinition
- Type: Autodesk.Revit.DB ExternalDefinition
Shared parameter definition.
Return Value
The newly created shared parameter instance.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | A shared parameter with the assigned GUID is already loaded into the document. |