This method tests whether this and the given curve elements are joined at the given end.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- end
- Type: System Int32
Index of one of the curve's end. Values '0' and '1' indicate the start or end point, respectively.
- other
- Type: Autodesk.Revit.DB ElementId
ElementId of another Curve Element from the same document.
Return Value
Returns True if the input curve element joins This curve element at the given end-point; returns False otherwise.Remarks
The input end is relative to this curve element. The other curve element can be joined at any of its end-points.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The given Id does not represent any of the two end-points of a curve element. A valid value of either '0' or '1' is expected. -or- The given ElementId (%elementId) is not of a valid Curve Element. A valid Curve Element must be in the same document and must be diferent than this curve elements self. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |