Connects a group of placeholders that can intersect in a Cross connection.
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- connector1
- Type: Autodesk.Revit.DB Connector
The end connector of the first placeholder.
- connector2
- Type: Autodesk.Revit.DB Connector
The end connector of the second placeholder.
- connector3
- Type: Autodesk.Revit.DB Connector
The end connector of the third placeholder.
- connector4
- Type: Autodesk.Revit.DB Connector
The end connector of the fourth placeholder.
Return Value
True if connection succeeds, false otherwise.Remarks
The placeholders may or may not have physical connection. However:
- The ends of four connectors should intersect at same point.
- The first and second placeholders should be collinear each other.
- The third and fourth placeholders should be collinear each other.
- The third and fourth should have intersection with first or second placeholder.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The owner of connector is not duct placeholder. -or- The owners of connectors belong to different types of system. -or- The curves of connector1 and connector2 are not collinear or either the connecto1 or connector2 is not connector of curve end. -or- The curves of connector3 and connector4 are not collinear or either the connecto1 or connector2 is not connector of curve end. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |