Creates a new PropertySetElement to contain the given asset.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document in which to create the PropertySetElement.
- thermalAsset
- Type: Autodesk.Revit.DB ThermalAsset
The thermal asset containing the values that will be present in the PropertySetElement.
Return Value
The new PropertySetElement.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown when the name of the asset is empty, contains prohibited characters, or is not unique |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |