SetSelectedElementIds Method


Sets the element ids of the elements to export. Used only when ExportScope = SelectedElements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public void SetSelectedElementIds(
	ICollection<ElementId> ids
)
Visual Basic
Public Sub SetSelectedElementIds ( _
	ids As ICollection(Of ElementId) _
)
Visual C++
public:
void SetSelectedElementIds(
	ICollection<ElementId^>^ ids
)

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also