Creates a new Solid which is the intersection of the input Solid with the half-space on the positive side of the given Plane. The positive side of the plane is the side to which Plane.Normal points.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- solid
- Type: Autodesk.Revit.DB Solid
The input Solid to be cut.
- plane
- Type: Autodesk.Revit.DB Plane
The cut plane. The space on the positive side of the normal of the plane will be intersected with the input Solid.
Return Value
The newly created Solid.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |