Adds member element ids for the assembly instance.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- memberIds
- Type: System.Collections.Generic ICollection ElementId
Element ids to be added to the assembly instance.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | One or more element ids was not permitted for membership in the assembly instance. Elements should be of a valid category and should not be a member of an existing assembly. -or- The provided set includes one or more element ids that cannot be added to or removed from the assembly on their own. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |