Implement this method to get operations supported by the external server for a particular type of external resource.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- extensions
- Type: Autodesk.Revit.DB ExternalResourceServerExtensions
The class which owns sub-interface classes, each of which has methods related to a particular type of external resource.
Remarks
Through this method, some specific operations for a paritcular type of external resource, such as Open(and Unload) and shared coordinates for Revit Link, can be set in a class ExternalResourceServerExtensions.
ExternalResourceServerExtensions is able to own sub-interface classes, each of which has methods related to a particular type of external resource.