Sets the characters in a given text range to be underlined or not underlined.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- textRange
- Type: Autodesk.Revit.DB TextRange
The given text range.
- isUnderlined
- Type: System Boolean
The desired underline status of characters in the given text range. True to set underlined, false to set not underlined.
Remarks
Bullets, numbers, or letters of a list can not be underlined.
The given text range should not be empty.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |