Adds users back to the list of displayed users and permits customization of the graphics. Any usernames that are not currently removed will be ignored. Returns the number of users who were actually restored.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- usersToRestore
- Type: System.Collections.Generic ICollection String
The usernames of the users to restore. Any usernames that are not currently removed will be ignored.
Return Value
The number of usernames that were actually restored.Remarks
This is the opposite of removing users. Note that the user will be shown with default graphic overrides - any customizations that existed prior to removing the user will not be restored.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |