Construct BRepBuilderEdgeGeometry based on any GCurve, including GLine and GArc. The curve will be simplified if possible, and the concrete type of the returned value will reflect that simplification: BRepBuilderLinearEdgeGeometry if the curve could be simplified to a line, BRepBuilderArcEdgeGeometry if it could be simplified to an arc, BRepBuilderGenericCurveEdgeGeometry otherwise.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- curve
- Type: Autodesk.Revit.DB Curve
The 3D curve for this edge. This BRepBuilderEdgeGeometry stores a copy of the input curve. The use of isCurveOpenOrShort as a validator instead of isCurveOpen is a compromise to allow the creation of geometry that is normally considered unacceptable due to edges that are shorter than Revit allows.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The input curve is not bound. -or- The curve is degenerate (its length is too close to zero). -or- The endpoints of the curve are close enough that Revit considers it a closed curve. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |