Reorders the sequence of Revisions in the project.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document in which the Revision sequence should be reordered.
- newSequence
- Type: System.Collections.Generic IList ElementId
The new sequence of Revisions.
Remarks
This method allows the caller to change the sequence of the Revisions within the project by specifying the new sequence. The specified sequence must include every Revision in the project exactly once.
Note that changing the sequence of Revisions can change the SequenceNumber and RevisionNumber of Revisions that have already been issued.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | newSequence does not contain every Revision exactly once. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |