Adds a new pushbutton to the pulldown button and associates it with an ExternalCommand.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- buttonData
- Type: Autodesk.Revit.UI PushButtonData
An object containing the data needed to construct the pushbutton.
Return Value
The newly added pushbutton.Remarks
The new button will display its large image if PushButton.LargeImage is set.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when buttonData is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions ArgumentException | Thrown when button with buttonData.Name already exists in the button. |