Combines the specified Revision with the previous Revision.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The Document containing the Revisions.
- revisionId
- Type: Autodesk.Revit.DB ElementId
The Revision that should have its clouds and tags associated with the previous Revision.
Return Value
The ids of all RevisionClouds that were reassigned to the previous Revision.Remarks
All RevisionClouds and tags associated with the specified Revision will be reassigned to the previous Revision in the model and the specified Revision will be deleted from the model. The operation can only be performed if both the specified Revision and the previous one are unissued.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | revisionId is not a valid Revision. -or- This operation cannot be performed because revisionId is an issued Revision. -or- revisionId cannot be combined with the previous Revision because either revisionId is the first Revision or the previous Revision has already been issued. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |