Constructs an instance of FilterGlobalParameterAssociationRule.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- valueProvider
- Type: Autodesk.Revit.DB FilterableValueProvider
A pointer to a "value provider" object that will extract values from a Revit document.
- evaluator
- Type: Autodesk.Revit.DB FilterNumericRuleEvaluator
A pointer to the filter rule evaluator object that implements the desired test. The built-in evaluators implement commonly used tests such as less-than, greater-than less-than-or-equal-to, equal, etc.
- ruleValue
- Type: Autodesk.Revit.DB ElementId
The user-supplied global parameter value against which values from a Revit document will be tested.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |