Returns all global paramters in an ordered array.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
Document containing the requested global parameters
Return Value
An array of Element Ids of all Global Parameters in the document.Remarks
The order of the items coresponds to the order at which global parameters appear in Revit UI when shown in the standard Global Parameters dialog. However, the order of parameters is serialized in the document, thus available on the DB level as well.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Global parameters are not supported in the given document. A possible cause is that it is not a project document, for global parameters are not supported in Revit families. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |