Inserts a new MEPSize in to the duct size settings. The duct shape determines the location of the new size in the size table.
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- shape
- Type: Autodesk.Revit.DB.Mechanical DuctShape
The shape of duct.
- sizeInfo
- Type: Autodesk.Revit.DB MEPSize
The new MEPSize to be added.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Throws if there is no size set determined by the duct shape or there is already the same size in the size set determined by the duct shape. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions InvalidOperationException | Throws if the function is called during iterating the size set. |