Retrieves the GUID representing this element in DWF and IFC export.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- elementId
- Type: Autodesk.Revit.DB ElementId
The id of the element.
Return Value
The value of the GUID representing the element in the export context.Remarks
This id is used in the contents of DWF export and IFC export and it should be used only when cross-referencing to the contents of these export formats. When storing Ids that will need to be mapped back to elements in future sessions, UniqueId must be used.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The element elementId does not exist in the document |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |