Set Location path for a spiral run.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- stairsRun
- Type: Autodesk.Revit.DB.Architecture StairsRun
The run whose location path will be set.
- center
- Type: Autodesk.Revit.DB XYZ
The center of the location arc of the spiral run. The Z coordinate of the center is the base elevation for the new run (in model coordinates). It must be greater than or equal to the stairs base elevation.
- radius
- Type: System Double
The radius of the location arc of the spiral run.
- startAngle
- Type: System Double
The start angle of the location arc of the spiral run. The angle's coordinate system is world coordinate system which always is XYZ.BasisX and XYZ.BasisY.
- includedAngle
- Type: System Double
The total angle covered by the spiral run. Must be a positive value (direction is determined by the clockwise flag).
- clockwise
- Type: System Boolean
True if the spiral run will be created along clockwise direction, False otherwise.
- justification
- Type: Autodesk.Revit.DB.Architecture StairsRunJustification
The location path justification of the new stairs run.
Return Value
Indicate if set is success or not.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The given value for startAngle is not finite -or- The input center is not a valid center for spiral run (probably the Z coordinate doesn't meet the restrictions) -or- The includedAngle doesn't satisfy riser restriction to generate spiral run (probably it's too small). |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | The given value for radius must be greater than 0 and no more than 30000 feet. -or- The given value for includedAngle must be positive. -or- A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions ArgumentsInconsistentException | The radius is too small to generate a spiral run at the given justification. |
Autodesk.Revit.Exceptions InvalidOperationException | The stairs element represented by stairsRun is not in an active StairsEditScope. The run cannot be modified. |
Autodesk.Revit.Exceptions RegenerationFailedException | The center, radius, startAngle, includedAngle don't satisfy restrictions to generate spiral run. |