Predefined message ids for DataExchangeLog.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2016
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Members
Member name | Description |
---|---|
None | No message. |
UnitOfProgressCompleted | That message will be sent at reasonable intervals to provide the using application an opportunity to update its progress indicator. |
ObjectCreated | An informational message. An object - a face, edge, solid, etc. - has been created successfully. |
UnexpectedResult | Unexpected result produced by a data conversion operation. Conversion may continue, but the results should be carefully reviewed. |
InvalidSourceObject | An error message. A source object was found to be invalid. |
InvalidDataSet | No data could be imported. Would typically be reported as a error. May be reported as a fatal error. |
GenericError | A catch-all error code. Used for errors that are not enumerated explicitly. |
ObjectNotSupported | A warning message. A source object was not converted. |
ObjectNotConverted | An error message. The conversion code was unable to process a valid supported source object. |
InvalidRenderingStyle | An error message. The conversion code was unable to process a render style. The created model will differ in visual appearance. |
EmptyObject | A warning level message. The conversion encountered an object with no data to convert. The object will be ignored. This may indicate a problem with incoming data. |