Sets the characters in a given text range to be bold or not bold.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- textRange
- Type: Autodesk.Revit.DB TextRange
The given text range.
- isBold
- Type: System Boolean
The desired bold status of characters in the given text range. True to set bold, false to set not bold.
Remarks
To make the numbers or letters in a list bold, apply the bold status to the carriage return character that ends the list paragraph.
The given text range should not be empty.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |