SetToBindHandleWithTarget Method


Sets the relationship between two RebarConstrainedHandles.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.1.1.1)
Since: 2020.1

Syntax

C#
public void SetToBindHandleWithTarget(
	bool bindsHandleWithTarget
)
Visual Basic
Public Sub SetToBindHandleWithTarget ( _
	bindsHandleWithTarget As Boolean _
)
Visual C++
public:
void SetToBindHandleWithTarget(
	bool bindsHandleWithTarget
)

Parameters

bindsHandleWithTarget
Type: System Boolean
False if only the constrained RebarConstrainedHandle follows the target. True if the constrained RebarConstrainedHandle and the target bar handle will be bound and move together.

Remarks

Throws exception for any type of constraint other than 'ToOtherRebar' or if the RebarTargetConstraintType of the constraint is 'HookBend' or 'BarBend'. Will also throw if the target Rebar has the 'Number with Spacing' layout rule and the RebarTargetConstraintType of the constraint is 'OutOfPlaneExtent'.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions DisabledDisciplineException None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions InvalidOperationException RebarConstraint is no longer valid. -or- The RebarConstraint is not of RebarConstraintType 'ToOtherRebar.' -or- The RebarTargetConstraintType is 'HookBend' or 'BarBend'. -or- The RebarTargetConstraintType is 'OutOfPlaneExtent' and the rebar target layout is 'Number with Spacing'.

See Also