The LoadBase object is the base class for all load objects within the Autodesk Revit API.
Namespace:
Autodesk.Revit.DB.Structure
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
Remarks
Load objects are only available in Autodesk Revit Structure. This object contains methods that are common to all other load objects.
Examples
Copy
C#
private void LoadBaseInformation(LoadBase loadBase)
{
string message = "LoadBase data for line load: ";
//Get the name of the load case to which this load belongs
message += "\nLoad case name: " + loadBase.LoadCaseName;
//Get the name of the category to which this load belongs
message += "\nLoad category name: " + loadBase.LoadCategoryName;
//A string representing the nature of the load
message += "\nLoad nature name: " + loadBase.LoadNatureName;
//show the load base information in the messagebox
TaskDialog.Show("Revit",message);
}
Copy
VB.NET
Private Sub LoadBaseInformation(loadBase As LoadBase)
Dim message As String = "LoadBase data for line load: "
'Get the name of the load case to which this load belongs
message += vbLf & "Load case name: " & Convert.ToString(loadBase.LoadCaseName)
'Get the name of the category to which this load belongs
message += vbLf & "Load category name: " & Convert.ToString(loadBase.LoadCategoryName)
'A string representing the nature of the load
message += vbLf & "Load nature name: " & Convert.ToString(loadBase.LoadNatureName)
'show the load base information in the messagebox
TaskDialog.Show("Revit", message)
End Sub
Inheritance Hierarchy
System
Object
Autodesk.Revit.DB Element
Autodesk.Revit.DB.Structure LoadBase
Autodesk.Revit.DB.Structure AreaLoad
Autodesk.Revit.DB.Structure LineLoad
Autodesk.Revit.DB.Structure PointLoad
Autodesk.Revit.DB Element
Autodesk.Revit.DB.Structure LoadBase
Autodesk.Revit.DB.Structure AreaLoad
Autodesk.Revit.DB.Structure LineLoad
Autodesk.Revit.DB.Structure PointLoad