StandardHookBendDiameter Property


Defines hook bend diameter for rebar whose style is standard

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public double StandardHookBendDiameter { get; set; }
Visual Basic
Public Property StandardHookBendDiameter As Double
	Get
	Set
Visual C++
public:
property double StandardHookBendDiameter {
	double get ();
	void set (double value);
}

Field Value

The hook bend diameter for rebar whose style is standard

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException When setting this property: the bend diameter standardHookBendDiam isn't between bar diameter and 99.0
Autodesk.Revit.Exceptions DisabledDisciplineException When setting this property: None of the following disciplines is enabled: Structural.

See Also