GetEndTreatmentTypeId Method


get the id of the end treatment for the designated shape end

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)
Since: 2017

Syntax

C#
public ElementId GetEndTreatmentTypeId(
	int iEnd
)
Visual Basic
Public Function GetEndTreatmentTypeId ( _
	iEnd As Integer _
) As ElementId
Visual C++
public:
ElementId^ GetEndTreatmentTypeId(
	int iEnd
)

Parameters

iEnd
Type: System Int32

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException iEnd not a valid shape end

See Also