Gets the id of the EndTreatmentType at the specified rebar shape end.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- iEnd
- Type: SystemInt32
0 for the start end treatment, 1 for the end end treatment.
Return Value
Returns the id of an EndTreatmentType, or invalidElementId if the rebar shape has no end treatment at the specified end.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | iEnd not a valid shape end |