Appends one vertex to the end of the wire.
Namespace:
Autodesk.Revit.DB.Electrical
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since:
2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- vertexPoint
-
Type:
Autodesk.Revit.DB
XYZ
The vertex to be appended.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The vertex point cannot be added to the wire because there is already a vertex at this position on the view plane (within tolerance). |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping. |
Autodesk.Revit.Exceptions InvalidOperationException | The end point is already connected to an element, so a new endpoint vertex cannot be appended. |