GetFilterVisibility Method


Gets the visibility of the elements associated with a filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public bool GetFilterVisibility(
	ElementId filterElementId
)
Visual Basic
Public Function GetFilterVisibility ( _
	filterElementId As ElementId _
) As Boolean
Visual C++
public:
bool GetFilterVisibility(
	ElementId^ filterElementId
)

Parameters

filterElementId
Type: Autodesk.Revit.DB ElementId
The ElementId of the filter.

Return Value

True if the elements associated with the filter are visible in the view, false otherwise.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException Filter is not applied to the view. -or- ElementId is not associated with a FilterElement.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions InvalidOperationException View does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes.

See Also