HideWhenNoValue Property


This property indicates whether this parameter should be hidden from the properties palette when it doesn't have a value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 20.0.0.0 (20.0.0.377)
Since: 2020

Syntax

C#
public bool HideWhenNoValue { get; set; }
Visual Basic
Public Property HideWhenNoValue As Boolean
	Get
	Set
Visual C++
public:
property bool HideWhenNoValue {
	bool get ();
	void set (bool value);
}

Field Value

True if the parameter should be hidden when it has no value, False if the parameter should remain visible in the properties palette even when it doesn't have a value. The default is false

See Also