AddPartCustomData Method


Add custom data type to the fabrication part. The new data gets the default value defined by the fabrication configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since: 2018

Syntax

C#
public bool AddPartCustomData(
	int customId
)
Visual Basic
Public Function AddPartCustomData ( _
	customId As Integer _
) As Boolean
Visual C++
public:
bool AddPartCustomData(
	int customId
)

Parameters

customId
Type: System Int32
The identifier of the custom data field to add.

Return Value

Returns true if the type was not already present.

Remarks

The custom id must be positive.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException The custom data id does not exist.

See Also