UpdateSpatialFieldPrimitive Method


Populates analysis results data (or replaces the existing data) in the existing primitive identified by the unique index

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public void UpdateSpatialFieldPrimitive(
	int idx,
	FieldDomainPoints fieldDomainPoints,
	FieldValues fieldValues,
	int resultIndex
)
Visual Basic
Public Sub UpdateSpatialFieldPrimitive ( _
	idx As Integer, _
	fieldDomainPoints As FieldDomainPoints, _
	fieldValues As FieldValues, _
	resultIndex As Integer _
)
Visual C++
public:
void UpdateSpatialFieldPrimitive(
	int idx, 
	FieldDomainPoints^ fieldDomainPoints, 
	FieldValues^ fieldValues, 
	int resultIndex
)

Parameters

idx
Type: System Int32
Unique index identifying the primitive
fieldDomainPoints
Type: Autodesk.Revit.DB.Analysis FieldDomainPoints
Set of domain points. If the new set of domain points is supplied, all previously supplied domain points and field values for all results are removed from the primitive. If %fieldDomainPoints% is a null reference ( Nothing in Visual Basic) only fieldValues are updated
fieldValues
Type: Autodesk.Revit.DB.Analysis FieldValues
Set of data values. Number of values in fieldValues must coincide with the number of points in fieldDomainPoints
resultIndex
Type: System Int32
Unique index identifying the result schema

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException idx refers to non-existent primitive -or- fieldValues has incorrect number of measurements in ValueAtPoint objects -or- fieldDomainPoints has inconsistent type -or- resultIndex refers to non-existent result schema
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions ArgumentsInconsistentException fieldDomainPoints and fieldValues have inconsistent number of points

See Also