Populates analysis results data (or replaces the existing data) in the existing primitive identified by the unique index
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- idx
- Type: SystemInt32
Unique index identifying the primitive
- fieldDomainPoints
- Type: Autodesk.Revit.DB.AnalysisFieldDomainPoints
Set of domain points. If the new set of domain points is supplied, all previously supplied domain points and field values for all results are removed from the primitive. If %fieldDomainPoints% is a null reference (Nothing in Visual Basic) only fieldValues are updated
- fieldValues
- Type: Autodesk.Revit.DB.AnalysisFieldValues
Set of data values. Number of values in fieldValues must coincide with the number of points in fieldDomainPoints
- resultIndex
- Type: SystemInt32
Unique index identifying the result schema
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | idx refers to non-existent primitive -or- fieldValues has incorrect number of measurements in ValueAtPoint objects -or- fieldDomainPoints has inconsistent type -or- resultIndex refers to non-existent result schema |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentsInconsistentException | fieldDomainPoints and fieldValues have inconsistent number of points |