UsesReference Method


Identifies if the PartMaker uses the intersecting reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public bool UsesReference(
	ElementId intersectingReference
)
Visual Basic
Public Function UsesReference ( _
	intersectingReference As ElementId _
) As Boolean
Visual C++
public:
bool UsesReference(
	ElementId^ intersectingReference
)

Parameters

intersectingReference
Type: Autodesk.Revit.DB ElementId
Intersecting reference to be tested.

Return Value

True if the intersecting reference is used by the PartMaker.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also