GetFilterOverrides Method


Gets graphic overrides that a filter applies to the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public OverrideGraphicSettings GetFilterOverrides(
	ElementId filterElementId
)
Visual Basic
Public Function GetFilterOverrides ( _
	filterElementId As ElementId _
) As OverrideGraphicSettings
Visual C++
public:
OverrideGraphicSettings^ GetFilterOverrides(
	ElementId^ filterElementId
)

Parameters

filterElementId
Type: Autodesk.Revit.DB ElementId
ElementId of the filter.

Return Value

Object representing all graphic overrides of the filter in the view.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException ElementId is not associated with a FilterElement. -or- Filter is not applied to the view.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions InvalidOperationException View does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes.

See Also