SetExternalItems Method


Sets the collection of externally added items which should be shown in the Transfer Project Standards dialog as options.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 18.0.0.0 (18.0.0.420)
Since: 2017.2

Syntax

C#
public void SetExternalItems(
	IDictionary<Guid, string> externalItems
)
Visual Basic
Public Sub SetExternalItems ( _
	externalItems As IDictionary(Of Guid, String) _
)
Visual C++
public:
void SetExternalItems(
	IDictionary<Guid, String^>^ externalItems
)

Parameters

externalItems
Type: System.Collections.Generic IDictionary Guid , String
The external items which are displayed in the Transfer Project Standards UI. GUIDvalue is used to identify the external item string.

Remarks

The externally added items that the user opted to transfer will be reported in the args to the TransferredProjectStandards event.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also